WordPress PHP 版本要求、MySQL 版本要求及 Apache 或 Nginx 版本要求

文 / @UTHEME

关于WordPress的PHP和MySQL版本要求

尽管WordPress是一个非常流行的开源内容管理系统,但它和其他PHP程序一样,对PHP版本和MySQL版本都有一定的要求。WordPress对PHP和MySQL版本的要求主要分为核心PHP版本要求、主题PHP版本要求和插件PHP版本要求。

WordPress核心的PHP和MySQL版本需求

根据WordPress的官方主机环境要求说明,WordPress建议主机环境符合以下要求:

  • PHP7.3或更高版本
  • MySQL5.6或更高版本,MariaDB10.0或更高版本
  • HTTPS支持

虽然Apache或者Nginx是运行WordPress最健壮和功能最丰富的服务器,但是使用其他支持PHP或MySQL的Web服务器也是可以的。

WordPress主题的PHP和MySQL版本需求

由于WordPress主题的开发者众多,各个主题对PHP版本的需求也都各不相同。WordPress目前没有提供判断主题PHP版本需求的方法。有些主题会把PHP版本需求写在readme.txt文件中,我们可以试着在这个文件里面寻找。如果找不到,可以在主题开发者提供的支持论坛中向主题开发者提问。

WordPress插件的PHP和MySQL版本要求

与主题不同,WordPress已经在官方插件目录中直接列出了插件的PHP版本需求。我们可以直接在插件介绍页面右侧的插件元信息中查看,如下图所示:

WordPress插件PHP版本需求

有些插件为了防止PHP版本不能满足需求而带来的致命错误,会在插件激活时,判断服务器的PHP版本以确定是否激活插件功能。

至于主题和插件对MySQL版本的需求,目前并没有比较直接的判断方法。但相对于PHP,MySQL版本的区别并不是太大,不至于版本不满足需求就直接出现致命错误而导致网站不能运行。

怎样确定主题提供的PHP和MySQL版本

直接向主题提供商咨询

如果您不确定您的Web服务器提供的PHP和MySQL版本,WordPress提供了一个简单的问题来帮助您向服务器提供商提问以弄清这个问题。您可以直接复制以下内容并发送给您的服务器提供商进行咨询。

我需要在我们的服务器上运行最新版本的WordPress,我想知道我的服务器是否支持以下内容:

1、PHP7.3或更高版本
2、MySQL5.6或更高版本,MariaDB10.0或更高版本
3、HTTPS支持
4、Nginx或带有mod_rewrite模块的Apache以支持UrlRewrite功能

在phpMyAdmin中查看

如果您的主题提供了phpMyAdmin功能,我们还可以在phpMyAdmin中查看PHP和MySQL版本信息,在phpMyAdmin的后台主页,找到如下界面即可查看。

及时更新PHP和MySQL或MariaDB版本

虽然较低的PHP或MySQL版本也能够运行WordPress,但为了安全起见,建议有条件的朋友及时升级到最新的版本。新的版本还会带来功能的增强和性能方面的提升。如果担心最新版本有Bug,可以升级到上一个稳定版本,并及时关注PHP或MySQL版本的支持信息。

添加UTHEME为好友
扫码添加UTHEME微信为好友
· 分享WordPress相关技术文章,主题上新与优惠动态早知道。
· 微信端最大WordPress社群,限时免费入群。